Peloton App Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Feb 14, 2023 - 16:21 EST
Update
We are continuing to investigate this issue.
Posted Jan 22, 2023 - 22:34 EST
Investigating
We are investigating an issue with the Peloton app. Achievement notifications including streaks and milestones may not appear on iOS during live classes.
Posted Jan 20, 2023 - 18:14 EST
This incident affected: Bike/Tread/App/Row (Peloton App).