Scenic Workouts Preview Issue
Incident Report for Peloton
Resolved
This incident has been resolved. We apologize for any interruption to your workout.
Posted Oct 07, 2022 - 11:48 EDT
Identified
Members are reporting issues when previewing a small number of scenic workouts. Our team is actively addressing the issue.
Posted Oct 07, 2022 - 10:31 EDT
This incident affected: Bike/Tread/App/Row (On Demand Classes).