Issues with Ally Love’s Live Class
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted May 10, 2020 - 14:32 EDT
Identified
There were some technical issues during Ally Love’s Live Ride from 1 PM ET. The class has been rescheduled to 1:30 PM ET.
Posted May 10, 2020 - 13:15 EDT
This incident affected: Bike/Tread/App/Row (Live Classes).