Latest iOS App higher than expected crash rate

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 10:09 EST

Update

We are continuing to monitor for any further issues.
Posted Jan 13, 2026 - 15:58 EST

Monitoring

A fix has been implemented and a new release has started to roll out, 15.119.2.
Posted Jan 13, 2026 - 12:07 EST

Identified

The team has identified an issue with the latest version of the iOS App 15.119.0 that is crashing frequent crashes. We advise members from upgrading to the latest version at this time and remain on 15.118.1 or lower.

If a member is on version 15.119.0 and is experiencing the crash, we recommend opening the app, turning off your screen and reopening the App to access.
Posted Jan 12, 2026 - 12:44 EST
This incident affected: Bike/Tread/App/Row (Peloton App).