Peloton Website Degraded Performance
Incident Report for Peloton
Resolved
The issues with our website's performance have now been resolved.
Posted Mar 22, 2022 - 23:18 EDT
Investigating
We are investigating an issue with our website. This may impact your ability to browse, shop, or log in.
Posted Mar 22, 2022 - 19:28 EDT
This incident affected: Website (Peloton Site - US (onepeloton.com), Peloton Site - Canada (onepeloton.ca), Peloton Site - UK (onepeloton.co.uk), Peloton Site - Germany (onepeloton.de), Peloton Apparel (apparel.onepeloton.com), Peloton Studio (studio.onepeloton.com), Peloton Support (support.onepeloton.com), Peloton Profile/Workout History (members.onepeloton.com), Peloton Returns (returns.onepeloton.com), Peloton Checkout (onepeloton.com/checkout)).