Workout Sharing Issue
Incident Report for Peloton
Resolved
This incident has been resolved
Posted Oct 04, 2021 - 20:26 EDT
Investigating
We are investigating an issue that is preventing sharing workouts to Facebook and Instagram.
Posted Oct 04, 2021 - 14:17 EDT
This incident affected: Integrations (Facebook, Instagram).