Some customers are experiencing issues with adding products to their cart completing checkout on onepeloton.com

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 17:41 EST

Investigating

We are currently investigating this issue.
Posted Jan 08, 2026 - 17:23 EST
This incident affected: Website (Peloton Site - (onepeloton.com)).