Strive Score History Degraded Performance
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 01, 2022 - 10:13 EDT
Identified
Strive Score History will be temporarily unavailable between 8:45 AM ET-10:30 AM ET today. Members will not be able to see their expected Strive Score when browsing classes in the class library. We apologize for any interruption to your workout.
Posted Oct 01, 2022 - 08:50 EDT
This incident affected: Bike/Tread/App/Row (On Demand Classes).